Question about Streaming Cube: Correct Kafka version

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Question about Streaming Cube: Correct Kafka version

Mu Kong
Hi,

I was trying to follow this post to create a streaming cube:
http://kylin.apache.org/docs20/tutorial/cube_streaming.html

When I tried to run a build from web GUI, there was nothing happening in
the web GUI page.
So, I tried to use RESTful API, but only got following exception:

"exception":"org.apache.kafka.clients.consumer.KafkaConsumer.assign(Ljava/util/Collection;)V"

The Kafka I used is 0.8, I wonder if it is the Kafka version is not
supported caused this exception.
Is it the case that Kylin does not, and will not, support Kafka v.0.8?

Best regards,
Mu
Reply | Threaded
Open this post in threaded view
|

Re: Question about Streaming Cube: Correct Kafka version

Billy Liu
0.8 is not supported. 0.10.1.0 is prefered.

2017-06-19 8:31 GMT+08:00 Mu Kong <[hidden email]>:

> Hi,
>
> I was trying to follow this post to create a streaming cube:
> http://kylin.apache.org/docs20/tutorial/cube_streaming.html
>
> When I tried to run a build from web GUI, there was nothing happening in
> the web GUI page.
> So, I tried to use RESTful API, but only got following exception:
>
> "exception":"org.apache.kafka.clients.consumer.KafkaConsumer.assign(Ljava/
> util/Collection;)V"
>
> The Kafka I used is 0.8, I wonder if it is the Kafka version is not
> supported caused this exception.
> Is it the case that Kylin does not, and will not, support Kafka v.0.8?
>
> Best regards,
> Mu
>
Reply | Threaded
Open this post in threaded view
|

Re: Question about Streaming Cube: Correct Kafka version

Mu Kong
Hi, Billy!

Thanks for your prompt response!
Could you please tell me whether the dev team is going to add support for
Kafka 0.8 in the future?
Or is it the case that Kylin will not support Kakfa 0.8?

Thanks!

Best regards,
Mu

On Mon, Jun 19, 2017 at 9:35 AM, Billy Liu <[hidden email]> wrote:

> 0.8 is not supported. 0.10.1.0 is prefered.
>
> 2017-06-19 8:31 GMT+08:00 Mu Kong <[hidden email]>:
>
> > Hi,
> >
> > I was trying to follow this post to create a streaming cube:
> > http://kylin.apache.org/docs20/tutorial/cube_streaming.html
> >
> > When I tried to run a build from web GUI, there was nothing happening in
> > the web GUI page.
> > So, I tried to use RESTful API, but only got following exception:
> >
> > "exception":"org.apache.kafka.clients.consumer.
> KafkaConsumer.assign(Ljava/
> > util/Collection;)V"
> >
> > The Kafka I used is 0.8, I wonder if it is the Kafka version is not
> > supported caused this exception.
> > Is it the case that Kylin does not, and will not, support Kafka v.0.8?
> >
> > Best regards,
> > Mu
> >
>
Reply | Threaded
Open this post in threaded view
|

Re: Question about Streaming Cube: Correct Kafka version

Billy Liu
Hi  Mu kong,

Kafka 0.8 is not on plan. But the 0.8 adaptation feature is welcomed very
much.

2017-06-19 8:46 GMT+08:00 Mu Kong <[hidden email]>:

> Hi, Billy!
>
> Thanks for your prompt response!
> Could you please tell me whether the dev team is going to add support for
> Kafka 0.8 in the future?
> Or is it the case that Kylin will not support Kakfa 0.8?
>
> Thanks!
>
> Best regards,
> Mu
>
> On Mon, Jun 19, 2017 at 9:35 AM, Billy Liu <[hidden email]> wrote:
>
> > 0.8 is not supported. 0.10.1.0 is prefered.
> >
> > 2017-06-19 8:31 GMT+08:00 Mu Kong <[hidden email]>:
> >
> > > Hi,
> > >
> > > I was trying to follow this post to create a streaming cube:
> > > http://kylin.apache.org/docs20/tutorial/cube_streaming.html
> > >
> > > When I tried to run a build from web GUI, there was nothing happening
> in
> > > the web GUI page.
> > > So, I tried to use RESTful API, but only got following exception:
> > >
> > > "exception":"org.apache.kafka.clients.consumer.
> > KafkaConsumer.assign(Ljava/
> > > util/Collection;)V"
> > >
> > > The Kafka I used is 0.8, I wonder if it is the Kafka version is not
> > > supported caused this exception.
> > > Is it the case that Kylin does not, and will not, support Kafka v.0.8?
> > >
> > > Best regards,
> > > Mu
> > >
> >
>